start - update cocoapods version ios




Atualizando para a versão mais recente do CocoaPods? (6)

Abaixo estão as etapas para atualizar os cocoapods:

  1. Terminal aberto (Atalho: Press cmd + space tab para abrir o Spotlight e o texto no terminal )
  2. Use o comando sudo gem install cocoapod s. Isso pedirá a senha do sistema devido a problemas de segurança.

  1. Agora, configure o pod usando o comando de pod setup . Isto irá configurar o repo master do cocoapods.

  1. Você pode verificar a versão dos cocoapods usando o comando pod --version .

Estou com problemas para instalar o Alamofire 4.0 no meu projeto.

Eu tenho a última versão do Xcode , rodando o Swift 3 , e quando eu tento instalar o alamofire, estou ficando com erros de 800 compiladores.

Pelo visto

O CocoaPods 1.1.0+ é necessário para construir o Alamofire 4.0.0+

Eu olhei para a versão do CocoaPods que tenho no terminal e ele diz que eu estou no 1.0.1.

Executar uma atualização não funcionou, eu acho, porque o CocoaPods 1.1 está na versão beta.

Então, não sei exatamente como atualizá-lo para onde estou indo. A menos que estar desatualizado não force como 800 erros de compilador? Isso soa como algum outro problema?


Abra o Terminal -> copy abaixo do comando

sudo gem install cocoapods

Ele instalará a última versão estável de cocoapods .

depois disso, você precisa atualizar o pod usando o comando abaixo

pod setup

Você pode verificar a versão do pod usando o comando abaixo

pod --version

Eu tentei atualizar e não funcionou. Finalmente, eu tive que remover completamente (manualmente) cocoapods, cocoapods-core, cocoapods-try .. qualquer outro uso de pacote por vagens de cacau. Use este comando terminal para listar todos os pacotes: gem list --local | grep cocoa pods gem list --local | grep cocoa pods

Depois disso, eu também excluo a pasta ./cocoapods da pasta raiz do usuário.


Execute o seguinte no seu terminal para obter a versão estável mais recente :

sudo gem install cocoapods

Adicione --pre para obter a última versão anterior:

sudo gem install cocoapods --pre

Se você estiver usando o Homebrew, abra o terminal e digite:

brew upgrade cocoapods

Se isso não funcionar, tente:

brew install cocoapods

Se você tiver ativado o System Integrity Protection ou qualquer outro erro de gravação de permissão, que é ativado por padrão desde a versão macOS Sierra, atualize o CocoaPods, executando esta linha no terminal:

gem install cocoapods

Após a instalação, verifique sua versão do pod:

gem which cocoapods

Você vai se livrar desse erro:

pod --version

E instalará os mais recentes CocoaPods:

sudo gem install cocoapods -n/usr/local/bin




alamofire