php - the - ubuntu instal laravel




Não é possível instalar o instalador laravel via compositor (8)

Estou tentando instalar o instalador laravel com o compositor no meu Ubuntu PC, mas recebo este erro durante a instalação. `Seus requisitos não puderam ser resolvidos para um conjunto instalável de pacotes.

  Problem 1
    - laravel/installer v1.4.1 requires ext-zip * -> the requested PHP extension zip is missing from your system.
    - laravel/installer v1.4.0 requires ext-zip * -> the requested PHP extension zip is missing from your system.
    - Installation request for laravel/installer ^1.4 -> satisfiable by laravel/installer[v1.4.0, v1.4.1].

  To enable extensions, verify that they are enabled in those .ini files:
    - /etc/php/7.0/cli/php.ini
    - /etc/php/7.0/cli/conf.d/10-opcache.ini
    - /etc/php/7.0/cli/conf.d/10-pdo.ini
    - /etc/php/7.0/cli/conf.d/20-calendar.ini
    - /etc/php/7.0/cli/conf.d/20-ctype.ini
    - /etc/php/7.0/cli/conf.d/20-exif.ini
    - /etc/php/7.0/cli/conf.d/20-fileinfo.ini
    - /etc/php/7.0/cli/conf.d/20-ftp.ini
    - /etc/php/7.0/cli/conf.d/20-gettext.ini
    - /etc/php/7.0/cli/conf.d/20-iconv.ini
    - /etc/php/7.0/cli/conf.d/20-json.ini
    - /etc/php/7.0/cli/conf.d/20-phar.ini
    - /etc/php/7.0/cli/conf.d/20-posix.ini
    - /etc/php/7.0/cli/conf.d/20-readline.ini
    - /etc/php/7.0/cli/conf.d/20-shmop.ini
    - /etc/php/7.0/cli/conf.d/20-sockets.ini
    - /etc/php/7.0/cli/conf.d/20-sysvmsg.ini
    - /etc/php/7.0/cli/conf.d/20-sysvsem.ini
    - /etc/php/7.0/cli/conf.d/20-sysvshm.ini
    - /etc/php/7.0/cli/conf.d/20-tokenizer.ini
  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.
`

O erro aparece, então eu uso este comentário:

composer global require "laravel/installer"

sudo apt-get instalar php-zip

Essa solução funcionou para mim.


Centos 7 com PHP7.2:

sudo yum --enablerepo=remi-php72 install php-pecl-zip

Estou usando o WSL com o Ubuntu 16.04 versão LTS com php 7.3 e laravel 5.7

sudo apt-get install php7.3-zip

Trabalhe para mim


No centos 7 eu usei:

yum install php-pecl-zip

porque qualquer outra solução não funcionou para mim.


Para PHP 7.2 no Ubuntu 18.04 LTS

sudo apt-get install php7.2-zip

Funciona como um encanto


Para o Ubuntu 16.04 , usei este comando para o PHP7.2 e funcionou para mim.

sudo apt-get install php7.2-zip

saber sua versão do php

php -v 

para php 7.3.0

sudo apt-get install php7.3-zip

extensão zip está faltando , você pode evitar esse erro por simples execução abaixo comando, ele terá versão por padrão

sudo apt-get install php-zip

No caso de você precisar de alguma versão específica, você precisa mencionar uma versão específica do seu php, suponha que eu precise instalar a versão X do php-zip, então o comando será.

sudo apt-get install phpX-zip  

Substitua X pela sua versão requerida. No meu caso, é X = 7.3