the - npm i @angular-devkit/build-angular




Não foi possível encontrar o módulo “@ angular-devkit/build-angular” (20)

Depois de atualizar para o Angular 6.0.1, recebo o seguinte erro no ng serve :

Could not find module "@angular-devkit/build-angular" from "/home/Projects/myProjectName".
Error: Could not find module "@angular-devkit/build-angular" from "/home/Projects/myProjectName".
    at Object.resolve (/home/Projects/myProjectName/node_modules/@angular-devkit/core/node/resolve.js:141:11)
    at Observable.rxjs_1.Observable [as _subscribe] (/home/Projects/myProjectName/node_modules/@angular-devkit/architect/src/architect.js:132:40)

ng update diz que tudo está em ordem. Excluir a pasta node_modules e uma nova npm install também não ajudou.

Meu projeto é baseado em [ng2-admin (versão Angular4)] ( https://github.com/akveo/ngx-admin ) Aqui está o meu package.json dependecies:

 "dependencies": {
    "@angular/animations": "^6.0.1",
    "@angular/common": "^6.0.1",
    "@angular/compiler": "^6.0.1",
    "@angular/core": "^6.0.1",
    "@angular/forms": "^6.0.1",
    "@angular/http": "^6.0.1",
    "@angular/platform-browser": "^6.0.1",
    "@angular/platform-browser-dynamic": "^6.0.1",
    "@angular/platform-server": "^6.0.1",
    "@angular/router": "^6.0.1",
    "@ng-bootstrap/ng-bootstrap": "1.0.0-alpha.26",
    "@ngx-translate/core": "^10.0.1",
    "@ngx-translate/http-loader": "^3.0.1",
    "amcharts3": "github:amcharts/amcharts3",
    "ammap3": "github:amcharts/ammap3",
    "angular-table": "^1.0.4",
    "angular2-csv": "^0.2.5",
    "angular2-datatable": "0.6.0",
    "animate.css": "3.5.2",
    "bootstrap": "4.0.0-alpha.6",
    "bower": "^1.8.4",
    "chart.js": "1.1.1",
    "chartist": "0.10.1",
    "chroma-js": "1.3.3",
    "ckeditor": "4.6.2",
    "core-js": "2.4.1",
    "easy-pie-chart": "2.1.7",
    "font-awesome": "4.7.0",
    "fullcalendar": "3.3.1",
    "google-maps": "3.2.1",
    "ionicons": "2.0.1",
    "jquery": "3.2.1",
    "jquery-slimscroll": "1.3.8",
    "leaflet": "0.7.7",
    "leaflet-map": "0.2.1",
    "lodash": "4.17.4",
    "ng2-ckeditor": "1.1.6",
    "ng2-completer": "^1.6.3",
    "ng2-handsontable": "^2.1.0-rc.3",
    "ng2-slim-loading-bar": "^4.0.0",
    "ng2-smart-table": "^1.0.3",
    "ng2-tree": "2.0.0-alpha.5",
    "ngx-uploader": "4.2.4",
    "normalize.css": "6.0.0",
    "roboto-fontface": "0.7.0",
    "rxjs": "^6.1.0",
    "rxjs-compat": "^6.1.0",
    "zone.js": "0.8.26"
  },
  "devDependencies": {
    "@angular/cli": "^6.0.1",
    "@angular/compiler-cli": "^6.0.1",
    "@types/fullcalendar": "2.7.40",
    "@types/jasmine": "2.5.38",
    "@types/jquery": "2.0.41",
    "@types/jquery.slimscroll": "1.3.30",
    "@types/lodash": "4.14.61",
    "@types/node": "6.0.69",
    "codelyzer": "3.0.1",
    "gh-pages": "0.12.0",
    "jasmine-core": "2.5.2",
    "jasmine-spec-reporter": "3.2.0",
    "karma": "1.4.1",
    "karma-chrome-launcher": "2.0.0",
    "karma-cli": "1.0.1",
    "karma-coverage-istanbul-reporter": "0.2.0",
    "karma-jasmine": "1.1.0",
    "karma-jasmine-html-reporter": "0.2.2",
    "npm-run-all": "4.0.2",
    "protractor": "5.1.0",
    "rimraf": "2.6.1",
    "standard-changelog": "1.0.1",
    "stylelint": "7.10.1",
    "ts-node": "2.1.2",
    "tslint": "5.2.0",
    "tslint-eslint-rules": "4.0.0",
    "tslint-language-service": "0.9.6",
    "typescript": "^2.7.2",
    "typogr": "0.6.6",
    "underscore": "1.8.3",
    "wintersmith": "2.2.5",
    "wintersmith-sassy": "1.1.0"
  }

e meu angular.json:

{
  "$schema": "./node_modules/@angular/cli/lib/config/schema.json",
  "version": 1,
  "newProjectRoot": "projects",
  "projects": {
    "ng2-admin": {
      "root": "",
      "sourceRoot": "src",
      "projectType": "application",
      "architect": {
        "build": {
          "builder": "@angular-devkit/build-angular:browser",
          "options": {
            "outputPath": "dist",
            "index": "src/index.html",
            "main": "src/main.ts",
            "tsConfig": "src/tsconfig.app.json",
            "polyfills": "src/polyfills.ts",
            "assets": [
              "src/assets",
              "src/favicon.ico"
            ],
            "styles": [
              "node_modules/roboto-fontface/css/roboto/sass/roboto-fontface.scss",
              "node_modules/normalize.css/normalize.css",
              "node_modules/font-awesome/scss/font-awesome.scss",
              "node_modules/ionicons/scss/ionicons.scss",
              "node_modules/bootstrap/scss/bootstrap.scss",
              "node_modules/leaflet/dist/leaflet.css",
              "node_modules/chartist/dist/chartist.css",
              "node_modules/fullcalendar/dist/fullcalendar.css",
              "node_modules/handsontable/dist/handsontable.full.css",
              "node_modules/ng2-slim-loading-bar/style.css",
              "src/app/theme/theme.scss",
              "src/styles.scss"
            ],
            "scripts": [
              "node_modules/jquery/dist/jquery.js",
              "node_modules/easy-pie-chart/dist/jquery.easypiechart.js",
              "node_modules/jquery-slimscroll/jquery.slimscroll.js",
              "node_modules/tether/dist/js/tether.js",
              "node_modules/bootstrap/dist/js/bootstrap.js",
              "node_modules/handsontable/dist/handsontable.full.js",
              "node_modules/chroma-js/chroma.js"
            ]
          },
          "configurations": {
            "production": {
              "optimization": true,
              "outputHashing": "all",
              "sourceMap": false,
              "extractCss": true,
              "namedChunks": false,
              "aot": true,
              "extractLicenses": true,
              "vendorChunk": false,
              "buildOptimizer": true,
              "fileReplacements": [
                {
                  "replace": "src/environments/environment.ts",
                  "with": "src/environments/environment.prod.ts"
                }
              ]
            }
          }
        },
        "serve": {
          "builder": "@angular-devkit/build-angular:dev-server",
          "options": {
            "browserTarget": "ng2-admin:build"
          },
          "configurations": {
            "production": {
              "browserTarget": "ng2-admin:build:production"
            }
          }
        },
        "extract-i18n": {
          "builder": "@angular-devkit/build-angular:extract-i18n",
          "options": {
            "browserTarget": "ng2-admin:build"
          }
        },
        "test": {
          "builder": "@angular-devkit/build-angular:karma",
          "options": {
            "main": "src/test.ts",
            "karmaConfig": "./karma.conf.js",
            "polyfills": "src/polyfills.ts",
            "tsConfig": "src/tsconfig.spec.json",
            "scripts": [
              "node_modules/jquery/dist/jquery.js",
              "node_modules/easy-pie-chart/dist/jquery.easypiechart.js",
              "node_modules/jquery-slimscroll/jquery.slimscroll.js",
              "node_modules/tether/dist/js/tether.js",
              "node_modules/bootstrap/dist/js/bootstrap.js",
              "node_modules/handsontable/dist/handsontable.full.js",
              "node_modules/chroma-js/chroma.js"
            ],
            "styles": [
              "node_modules/roboto-fontface/css/roboto/sass/roboto-fontface.scss",
              "node_modules/normalize.css/normalize.css",
              "node_modules/font-awesome/scss/font-awesome.scss",
              "node_modules/ionicons/scss/ionicons.scss",
              "node_modules/bootstrap/scss/bootstrap.scss",
              "node_modules/leaflet/dist/leaflet.css",
              "node_modules/chartist/dist/chartist.css",
              "node_modules/fullcalendar/dist/fullcalendar.css",
              "node_modules/handsontable/dist/handsontable.full.css",
              "node_modules/ng2-slim-loading-bar/style.css",
              "src/app/theme/theme.scss",
              "src/styles.scss"
            ],
            "assets": [
              "src/assets",
              "src/favicon.ico"
            ]
          }
        },
        "lint": {
          "builder": "@angular-devkit/build-angular:tslint",
          "options": {
            "tsConfig": [
              "src/tsconfig.app.json",
              "src/tsconfig.spec.json"
            ],
            "exclude": []
          }
        }
      }
    },
    "ng2-admin-e2e": {
      "root": "",
      "sourceRoot": "",
      "projectType": "application",
      "architect": {
        "e2e": {
          "builder": "@angular-devkit/build-angular:protractor",
          "options": {
            "protractorConfig": "./protractor.conf.js",
            "devServerTarget": "ng2-admin:serve"
          }
        },
        "lint": {
          "builder": "@angular-devkit/build-angular:tslint",
          "options": {
            "tsConfig": [
              "e2e/tsconfig.e2e.json"
            ],
            "exclude": []
          }
        }
      }
    }
  },
  "defaultProject": "ng2-admin",
  "schematics": {
    "@schematics/angular:component": {
      "prefix": "app",
      "styleext": "scss"
    },
    "@schematics/angular:directive": {
      "prefix": "app"
    }
  }
}

Solução simples

Clique abaixo apenas para corrigir esse erro

npm install --save-dev @angular-devkit/build-angular

Basta executar o seguinte comando e o erro foi resolvido

  • ng update @angular/cli @angular/core
  • npm uninstall @angular-devkit/build-angular
  • npm install --save-dev @angular-devkit/build-angular

    se este erro não puder ser resolvido pelo comando acima, você atualizará a versão do nó

    • npm update npm -g

Estou enfrentando o mesmo problema desde 2 dias.

ng -v :6.0.8
node -v :8.11.2
npm -v :6.1.0

Certifique-se de estar na pasta em que o angular.json está instalado. Entre nisso e digite ng serve . Se o problema ainda surgir, você estará tendo apenas dependências instaladas em node_modules . Digite o seguinte e ele funcionará:

npm i --only=dev

Eu lutei com o mesmo problema há um minuto atrás. Meu projeto foi gerado usando o v 1.6.0 do angular-cli.

1. npm update -g @angular/cli

2. editing my package.json changing the line
    "@angular/cli": "1.6.0",
      to
    "@angular/cli": "^1.6.0",

3. npm update

Espero que minha ajuda seja eficaz ツ


Eu tive o mesmo problema hoje, depois de atualizar o nó da v9 para a v10.
Meu ambiente é definido pelo docker e tive que remover esse comando do meu DockerFile:

npm link @angular/cli

Cria um symlink para o diretório onde o nó está instalado.
Eu acho que o módulo angular/cli nele não tem a mesma versão que a do diretório node_modules do meu projeto, e isso causa o problema.


Exclua package-lock.json e faça o npm instalar novamente. Deve corrigir o problema.

** Esta correção é mais adequada quando você criou o aplicativo Angular 6 usando o ng new e depois de instalar outras dependências você encontra este erro.


Infelizmente, nenhuma das soluções fornecidas funcionou perfeitamente para mim, mas a resposta de grepit me inspirou a fazer os seguintes passos. Eu desinstalei node.js através do meu sistema operacional (Windows 10) e instalei novamente. Em seguida, instalado o CLI Angular. Em seguida, criei um novo projeto e copiei o arquivo src do meu projeto antigo para este novo e o erro desapareceu.

Aqui estão as instruções:

  1. Desinstale node.js através do seu sistema operacional e instale-o novamente
  2. npm install -g @angular/cli
  3. Renomeie seu projeto para YOUR_PROJECT_NAME.old
  4. ng new YOUR_PROJECT_NAME
  5. Execute este projeto hello world ( ng serve ) para ter certeza de que você não receberá o erro.
  6. xcopy YOUR_PROJECT_NAME.old\src\*.* YOUR_PROJECT_NAME\src /s
    Esta é a versão do Windows da cópia, altere-a com base em seu próprio sistema operacional.

Instale @angular-devkit/build-angular como dependência dev. Este pacote foi recentemente introduzido no Angular 6.0

npm install --save-dev @angular-devkit/build-angular

ou,

yarn add @angular-devkit/build-angular --dev


No meu caso, o problema é devido a falta de dependências. Por que dependências estão faltando, porque eu esqueci de chamar:

npm install

Depois de chamar o comando acima, todas as dependências necessárias são carregadas em node_modules e isso não é mais problema


Os seguintes comandos funcionam:

npm install
ng update

-Você pode ver a mensagem "Nós analisamos seu pacote.json e tudo parece estar em ordem. Bom trabalho!"

npm update

Então tente dev build

ng build 

Eu recebi o erro com o script de tipo, rebaixei para

npm install [email protected]">=3.1.1 <3.2

ng build --prod 

Todo sucesso com compilação de prod.

Abaixo está a combinação de trabalho

ng --version

Package                           Version
-----------------------------------------------------------
@angular-devkit/architect         0.11.0
@angular-devkit/build-angular     0.11.0
@angular-devkit/build-optimizer   0.11.0
@angular-devkit/build-webpack     0.11.0
@angular-devkit/core              7.1.0
@angular-devkit/schematics        7.1.0
@angular/cli                      7.1.0
@ngtools/webpack                  7.1.0
@schematics/angular               7.1.0
@schematics/update                0.11.0
rxjs                              6.3.3
typescript                        3.1.6
webpack                           4.23.1

Quando executamos comandos como ng serve , ele usa a versão local de @ angular / cli. Então, primeiro instale a versão mais recente do @ angular / cli localmente (sem o sinalizador -g). Em seguida, atualize o CLI usando o comando ng update @angular/cli . Eu acho que isso deve resolver o problema. obrigado

Este link pode ajudá-lo se você estiver atualizando seu projeto angular https://update.angular.io/


Se o seguinte comando não funcionar,

npm install --save-dev @angular-devkit/build-angular

em seguida, vá para a pasta do projeto e execute este comando:

npm install --save @angular-devkit/build-angular

Tente isso. Funcionou para mim

npm uninstall -g @angular/cli
npm cache verify
npm install -g @angular/[email protected]

Todas as respostas acima estão corretas, mas não funcionaram para mim. A única maneira que consegui fazer este trabalho foi seguir os passos / comandos:

npm uninstall -g @angular/[email protected]
npm cache clean --force
npm install -g @angular/[email protected]
npm install node-sass -g
ng new MY_PROJECT_NAME
cp -r from_my_old_project to_new_MY_PROJECT_NAME

executando o seguinte trabalhado para mim npm audit fix --force


para angular 6 e acima

A solução de trabalho para mim foi

npm install

ng update

e finalmente

npm update


Execute abaixo o comando na sua CLI:

  • npm install

npm install Basta digitar npm install e run.Then o projeto será executado sem erros. Ou você pode usar o npm install --save-dev @angular-devkit/build-angular


npm update

Funcionou como um encanto.


  • Exclua os node_modules.
  • Limpe o cache usando 'npm cache clean --verify'.
  • E então o npm é instalado novamente.

Funciona como um encanto para mim.