was - update angular compiler




ERROR em The Angular Compiler requer TypeScript>=3.1.1 e<3.2.0 mas 3.2.1 foi encontrado (4)

Estou recebendo este erro

ERROR em The Angular Compiler requer TypeScript> = 3.1.1 e <3.2.0 mas 3.2.1 foi encontrado em seu lugar.

Parece que o Typescript foi atualizado, mas o Angular Compiler não gosta disso.

Como faço para corrigir isso?


No meu caso abaixo comando funcionou para o windows. Ele instalará a versão mais recente requerida entre 3.1.1 e 3.2.0. Dependendo do sistema operacional, use aspas duplas ou simples

npm install [email protected]">=3.1.1 <3.2.0" 

Para corrigir isso, instale a versão específica do typescript 3.1.6

npm i [email protected].1.6 --save-dev --save-exact

Tem um erro semelhante no log de erros do CircleCi.

"ERROR em The Angular Compiler requer TypeScript> = 3.1.1 e <3.3.0 mas 3.3.3333 foi encontrado em seu lugar."

Só assim você sabe que isso não afetou o aplicativo Angular, mas o erro do CircleCi estava ficando chato. Estou executando o Angular 7.1

Eu corri: $ npm i [email protected] --save-dev --save-exato para atualizar o arquivo package-lock.json.

Então eu corri: $ npm i

Depois disso, executei: correção de auditoria de $ npm

"Esta mensagem de erro do CircleCi" foi embora. Então funciona


npm install [email protected]">=3.1.1 <3.3.0" --save-dev --save-exact
rm -rf node_modules
npm install




angular-cli