node_modules/rxjs/internal/types.d.ts(81,44): erro TS1005: ';' erro esperado após a instalação do Angular 6




typescript build (8)

Anteriormente, eu costumava consertar o problema com a resposta do @Param, mas ultimamente comecei a usar o fio. Infelizmente eu não consegui encontrar fios equivalentes

nmp update

Eu tentei usar

yarn upgrade

(embora não seja equivalente do comando acima afaik) e não ajudou.

Eu usei

yarn add [email protected].0.0

e funcionou. Demorou um tempo considerável de 82 segundos em comparação com alguns segundos no caso de npm, mas resolveu o problema. meu nó 8.11.2 e fio 1.15.2

Eu tenho um erro de node_modules/rxjs/internal/types.d.ts(81,44): error TS1005: ';' expected. node_modules/rxjs/internal/types.d.ts(81,44): error TS1005: ';' expected. após a instalação do Angular 6.

Verifique o erro:

ERROR in node_modules/rxjs/internal/types.d.ts(81,44): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(81,74): error TS1005: ';' expected.
node_modules/rxjs/internal/types.d.ts(81,77): error TS1109: Expression expected.

Esse problema pode surgir devido à incompatibilidade de versão. Para resolver seu problema, você precisa fazer as seguintes alterações no seu arquivo package.json .

Passo 1 : Vá para package.json e modifique "rxjs": "^6.0.0" para "rxjs": "6.0.0"

Etapa 2 Execute a npm update no seu projeto.

Não há necessidade de alterar a versão digitada. (Meu: "typescript": "~2.7.2" )

Edit: Se você estiver usando rxjs-compat então você também precisa fazer o seguinte, a fim de corrigir o problema. altere a versão do rxjs-compat de "rxjs-compat": "^6.2.2" para "rxjs-compat": "6.2.2"

Espero que isso ajude!




Se você ainda estiver enfrentando o problema, vá para package.json

  1. remova o rxjs e adicione o rxjs-compat também, "rxjs-compat": "^ 6.4.0" para "rxjs-compat": "6.4.0",

  2. altere a versão do typscript para 2.8

  3. executar a instalação do npm

Isso vai funcionar para você!


Se você estiver usando o rxjs-compat, também precisará fazer o seguinte para corrigir o problema. alterar a versão do rxjs-compat de

"rxjs-compat": "^6.2.2" 

para

"rxjs-compat": "6.2.2"

Isso funciona para mim


Vá para package.json e atualize "rxjs": "^ 6.0.0" para "rxjs": "6.0.0" depois disso, faça a atualização npm


Você precisa fazer algumas alterações no package.json

Vá para package.json e modifique "rxjs": "^6.0.0" para "rxjs": "6.0.0"

Em seguida, execute a npm update no seu projeto





rxjs