javascript - hugo - tableless php




Existe um link para a "mais recente" biblioteca do jQuery nas APIs do Google? (8)

Esta questão já tem uma resposta aqui:

Eu uso o seguinte para um link jQuery em minhas tags <script> :

http://ajax.googleapis.com/ajax/libs/jquery/1.2.6/jquery.js

Existe um link para a versão "mais recente"? Algo como o seguinte (que não funciona):

http://ajax.googleapis.com/ajax/libs/jquery/latest/jquery.js

(Obviamente, não é necessariamente um ótimo plano para vincular seu código a bibliotecas em potencial, mas é útil no desenvolvimento.)





O jQuery também não permite que você chame o arquivo mais recente por SSL, uma consideração se você quiser usar o jQuery em um carrinho de compras, etc.

por exemplo

<script type="text/javascript" src="https://code.jquery.com/jquery-latest.min.js"></script>

lhe dará um erro de segurança.

A API do Google permitirá que você chame por SSL:

<script type="text/javascript" src="https://www.google.com/jsapi"></script>
<script type="text/javascript">
  google.load("jquery", "1.7");
</script>


Usar:

<script type="text/javascript" src="//www.google.com/jsapi"></script>
<script type="text/javascript">
//<![CDATA[
    google.load("jquery", "1");
    //google.load("jqueryui", "1");
    //google.load("swfobject", "1");
//]]>
</script>

Nota: O snippet acima vai ficar com o 1.7.1 ou 1.11.1.

Meu conselho para produção é codificar a versão jQuery do CDN: <script src="//ajax.googleapis.com/ajax/libs/jquery/2.1.4/jquery.min.js"></script>

Você pode encontrar as bibliotecas mais recentes do Google CDN aqui: https://developers.google.com/speed/libraries/

Ou use o jQuery CDN: https://code.jquery.com/



Até o jQuery 1.11.1 , você poderia usar os seguintes URLs para obter a versão mais recente do jQuery:

Por exemplo:

<script src="http://code.jquery.com/jquery-latest.min.js"></script>

No entanto, desde o jQuery 1.11.1, tanto o jQuery quanto o Google pararam de atualizar esses URLs; eles serão fixados para sempre em 1.11.1. Não há nenhum URL alternativo compatível para usar. Para uma explicação de porque este é o caso, veja este post no blog; blog.jquery.com/2014/07/03/dont-use-jquery-latest-js .

Ambos os hosts suportam https e http , portanto, altere o protocolo como quiser (ou use um URI relativo ao protocolo )

Veja também: https://developers.google.com/speed/libraries/devguide





google-api