macos - studio - site do r




Instalando o R no Mac-Mensagens de aviso: A configuração LC_CTYPE falhou, usando “C” (4)

  1. Terminal Aberto
  2. Escreva ou cole em: defaults write org.R-project.R force.LANG en_US.UTF-8
  3. Fechar terminal
  4. Comece R

Eu gostaria de instalar o R ​​no meu laptop Mac OS X versão 10.7.3

Eu baixei a última versão e dou um duplo clique nela e ela foi instalada, quando eu inicio eu recebo o seguinte erro, procurei na internet mas não consegui resolver o problema, qualquer ajuda seria apreciada

os erros são

Durante a inicialização - Mensagens de aviso:
1: A configuração de LC_CTYPE falhou, usando "C"
2: A configuração LC_COLLATE falhou, usando "C"
3: A configuração LC_TIME falhou, usando "C"
4: Configuração LC_MESSAGES falhou, usando "C"
5: Configuração LC_PAPER falhou, usando "C"
[R.app GUI 1.50 (6126) x86_64-apple-darwin9.8.0]

AVISO: você está usando uma localidade não-UTF8, portanto somente os caracteres ASCII funcionarão. Por favor, leia R para Mac OS X FAQ (veja Ajuda) seção 9 e ajuste suas preferências de sistema de acordo. [Histórico restaurado de / Uss/nemo/.Rapp.history]


Basta abrir o R ​​(software) e copiar e colar

system("defaults write org.R-project.R force.LANG en_US.UTF-8")

Espero que isso funcione bem ou use o outro método

open(on mac): Utilities/Terminal copy and paste

defaults write org.R-project.R force.LANG en_US.UTF-8

e feche o terminal e o R e reabra o R


Eu encontrei um problema ligeiramente diferente rodando R através do terminal mac, mas conectando-me remotamente a um servidor Ubuntu, o que me impediu de instalar uma biblioteca com sucesso.

A solução que tenho foi descobrir qual variável "LANG" é usada no terminal do Ubuntu

Ubuntu > echo $LANG
en_US.TUF-8

Eu recebi a resposta "en_US.TUF-8" do Ubuntu.

Na sessão R, no entanto, recebi "UTF-8" como o valor padrão e ele reclamou que a LC_TYPEC Setting LC_CTYPE failed, using "C"

R> Sys.getenv("LANG")
"UTF-8"

Então, tentei alterar essa variável em R. Funcionou.

R> Sys.setenv(LANG="en_US.UTF-8")

No meu Mac r é instalado em /usr/local/bin/r , adicione a linha abaixo em .bash_profile resolvido o mesmo problema:

alias r="LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 r"




install