tools - eclipse for android developers download




Como posso atualizar meu ADT no Eclipse? (5)

Eu tentei atualizar meu Eclipse. Atualmente tenho até 2.2 Android SDK no meu Eclipse. Ontem eu atualizei meu Eclipse assim:

Eclipse -> janela -> Android SDK Manager -> Eu marquei duas caixas de seleção da lista. Ferramentas -> Android SDK Tools e Android SDK Platform Tools.

Eu postei aqui algumas últimas linhas da mensagem que recebo do download e da instalação:

Preparando para instalar arquivos
Fazendo o download das ferramentas de plataforma do Android SDK, revisão 12
Instalando as ferramentas da plataforma Android SDK, revisão 12
Parando o servidor ADB com êxito.
Ferramentas da plataforma do SDK do Android instaladas, revisão 12
Download de ferramentas do Android SDK, revisão 20
Instalando o Android SDK Tools, revisão 20
[post_tools_install.bat] Atualizando o SDK Manager.exe
[post_tools_install.bat] 1 arquivo (s) copiado (s).
[post_tools_install.bat] Atualizando o AVD Manager.exe
[post_tools_install.bat] 1 arquivo (s) copiado (s).
Ferramentas do SDK do Android instaladas, revisão 20
Parando o servidor ADB com êxito.
Iniciando o servidor ADB com êxito.
Feito. 2 pacotes instalados.
Buscando URL: https://dl-ssl.google.com/android/repository/addon.xml
Falha ao buscar URL https://dl-ssl.google.com/android/repository/addon.xml , razão: dl-ssl.google.com
Buscando URL: http://software.intel.com/sites/landingpage/android/addon.xml
Falha ao buscar o URL http://software.intel.com/sites/landingpage/android/addon.xml , razão: software.intel.com
Feito o carregamento de pacotes.

Mas depois de tudo isso depois de ter fechado o Eclipse e novamente queria começar, ele lança o erro:

Este Android SDK requer a versão 20.0.0 ou superior do Android Developer Toolkit. A versão atual é 16.0.0.v201203301601-306762. Por favor, atualize o ADT para a versão mais recente.

Nas preferências, recebi este erro:

Este Android SDK requer Android Develop ... Por favor, atualize o ADT para a versão mais recente.


Correndo como administrador, em seguida, seguindo outros comentários corrigiu o problema para mim :)


Eu tive esse problema. Como eu já tinha o endereço dl-ssl.google.com/android/eclipse não consegui seguir a correção sugerida. A razão pela qual a atualização não estava funcionando no meu caso é que o endereço ADT não foi verificado na lista de "Atualizações disponíveis".

1) Ir para eclipse> help> Instalar novo software

2) Clique em "Site de Software Disponível"

3) Verifique se você tem o endereço ADT

4) Se não adicioná-lo seguindo os passos da Murtuza Kabul

5) se sim, verifique se o endereço está marcado (caixa de seleção à esquerda do endereço)

Eu executo a atualização depois de ter lançado o Eclipse como administrador para ter certeza de que não haveria problemas para acessar as pastas do sistema


Eu vi a documentação do Eclipse ADT e descobri o caminho para contornar este problema. Eu era capaz de atualizar minha ferramenta SDK para 22.0.4 (versão mais recente).

A solução é : primeiro atualizar ADT para 22.0.4 e, em seguida, atualizar a ferramenta SDK para 22.0.4

O link acima diz:

O ADT 22.0.4 foi projetado para uso com o SDK Tools r22.0.4 . Se você ainda não instalou o SDK Tools r22.0.4 no seu SDK, use o Gerenciador do Android SDK para fazer isso

O que eu tive que fazer foi atualizar meu ADT para 22.0.4 (versão mais recente) e, em seguida, eu era capaz de atualizar a ferramenta SDK para 22.0.4 . Eu pensei que apenas SDK Tool foi atualizado não ADT, então eu estava atualizando a ferramenta SDK com versão mais antiga do ADT (22.0.1).

Como atualizar seu ADT para a versão mais recente

  1. No Eclipse, vá para Help

  2. Install New Software ---> Add

  3. dentro de Adicionar Repositório escreva o Nome: ADT (ou o que você quiser)

  4. Localização: https://dl-ssl.google.com/android/eclipse/

  5. após o carregamento, você deve obter Ferramentas de Desenvolvedor e Plugins NDK

  6. verifique ambos se você quiser usar o Kit de Desenvolvimento Nativo (NDK) no futuro ou verificar

  7. Apenas ferramenta de desenvolvedor

  8. clique em Avançar

  9. Terminar


No meu caso, abrir 'Ajuda' >> "Instalar Novo Software" não tinha entradas para nenhum URL (URLs anteriores não estavam lá) - então eu adicionei-as manualmente. E atualizado ... e Voilaaaa !! As postagens acima foram muito úteis para resolver esse problema para mim.


Você atualizou o sdk do Android, mas não atualizou o adt para combinar com ele.

Você pode atualizar o adt daqui

Pode ser necessário atualizar a fonte do software para sua atualização do adt

Vá para eclipse> help> Verificar atualizações.

Deve listar a última atualização do adt. Se não estiver funcionando tente o mesmo * Vá para eclipse> help> Instalar novo software * mas agora por favor faça o seguinte:

Ele listará as atualizações disponíveis, que devem ser idealmente adt 20.xx

O Eclipse será reiniciado e esperamos que tudo funcione bem para você.





adt