ios - preferslargetitles - xcode big title




Xcode 6 с iOS 9? (6)

Вам необходимо установить Xcode 7 для разработки под iOS 9. Вы можете поддерживать работу Xcode 6 вместе с Xcode 7

Я довольно новичок в разработке для iOS, и я обновил свое устройство до iOS 9.0 beta, чтобы увидеть, как сработало мое приложение. Однако я не обновился до Xcode 7 beta. Я получаю сообщение об ошибке, в котором говорится, что мое устройство «не соответствует требованиям», в частности,

iPhone (3) может работать под управлением версии iOS, которая не поддерживается этой версией Xcode.

Это стандарт? Нужно ли обновляться до Xcode 7, если я использую iOS 9.0?


Вот простой обходной путь - особенно если у вас есть доступ к Xcode 7 на другом компьютере (но вы можете сделать это и на том же Mac):

Разверните любое приложение, например пример кода Apple, из Xcode 7 один раз. Затем вернитесь к Xcode 6.4, и он больше не будет считать устройство «неприемлемым».


Как уже упоминалось @Ben, вам нужно скачать XCode7, дата выпуска которого сейчас прямо на углу (середина сентября), но вам НЕ нужно создавать приложение под XCode7. Хитрость заключается в том, чтобы позволить XCode7 копировать символы. Сделав это, вы можете создать свое приложение на своем устройстве под XCode 6.4 и без поддержки Swift 2.0: тогда ваше устройство будет распознано. Так что да, вам нужно будет сохранить копии XCode 6 и XCode 7 по этому вопросу.


Проблема с Xcode 7 состоит в том, что он хочет изменить ваш быстрый код, чтобы иметь возможность работать. Здесь есть способ. Загрузите Xcode 7 и запустите его. Через несколько минут после некоторых установок подключите ваше устройство iOS 9 к компьютеру, чтобы увидеть его в Xcode 7. Затем выйдите из Xcode 7 и запустите Xcode 6, и неожиданно Xcode 6 обнаружит ваше устройство и вы сможете запустить на нем свое приложение.


Это просто.

  1. Скачать Xcode 7 или 7.1
  2. В поиске Найдите в обоих приложениях XCode следующий каталог. Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport
  3. Скопируйте папки 9.0 и 9.1 в Xcode 6 в том же каталоге.
  4. Перезапустите Xcode и снова подключите ваше устройство iOS 9.

Kaboom


Вы можете запустить приложение на устройстве iOS 9, используя Xcode 6, но сначала вам нужно построить приложение на XCode 7, после этого оно будет поддерживать XCode 6. Я проверил это на своем Mac.

меры

Создайте проект на Xcode 7, в то время как Xcode 6 открыт в том же проекте. Отключите устройство и подключите его снова. (Теперь вы можете запустить ваше приложение на XCode6, загрузка устройства может занять немного времени)

Когда я проверил iOS9 с Xcode6, ошибок стало меньше. Так что я планирую поддерживать iOS9 с XCode6 для быстрого выпуска. Позже я сделаю для XCode7.





ios9