Apache Airflow: initdb воздушного потока приводит к «ImportError: Нет модуля с именем json»




python-2.7 ubuntu-16.04 (2)

В Ubuntu 16.04 с версией Python 2.7 по умолчанию я пытаюсь установить воздушный поток Apache, но столкнулся с несколькими проблемами, и в настоящее время я вижу на

apache initdb 
Traceback (most recent call last):
  File "/usr/local/bin/airflow", line 21, in <module>
    from airflow import configuration
  File "/usr/local/lib/python2.7/dist-packages/airflow/__init__.py", line 40, in <module>
    from flask_admin import BaseView
  File "/usr/local/lib/python2.7/dist-packages/flask_admin/__init__.py", line 6, in <module>
    from .base import expose, expose_plugview, Admin, BaseView, AdminIndexView  # noqa: F401
  File "/usr/local/lib/python2.7/dist-packages/flask_admin/base.py", line 6, in <module>
    from flask import Blueprint, current_app, render_template, abort, g, url_for
  File "/usr/local/lib/python2.7/dist-packages/flask/__init__.py", line 20, in <module>
    from .app import Flask
  File "/usr/local/lib/python2.7/dist-packages/flask/app.py", line 69, in <module>
    from .wrappers import Request
  File "/usr/local/lib/python2.7/dist-packages/flask/wrappers.py", line 14, in <module>
    from werkzeug.wrappers.json import JSONMixin as _JSONMixin
ImportError: No module named json

Пробовал эти вещи до сих пор:


$ sudo apt-get install build-essential autoconf libtool pkg-config python-opengl python-imaging python-pyrex python-pyside.qtopengl idle-python2.7 qt4-dev-tools qt4-designer libqtgui4 libqtcore4 libqt4-xml libqt4-test libqt4-script libqt4-network libqt4-dbus python-qt4 python-qt4-gl libgle3 python-dev
sudo pip install -U Werkzeug==0.14.1

sudo pip install -U Jinja2==2.10.1

Также попробовал

pip install jsonate

pip install json # (this did not work)
 python
Python 2.7.12 (default, Nov 12 2018, 14:36:49)
[GCC 5.4.0 20160609] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import json
>>> exit()

Пока ничего не получалось.


На Mac при установке apache-airflow я получил следующую ошибку:

ОШИБКА: apache-airflow 1.10.3 имеет требование jinja2 <= 2.10.0,> = 2.7.3, но у вас будет jinja2 2.10.1, что несовместимо. ОШИБКА: apache-airflow 1.10.3 имеет требование werkzeug <0.15.0,> = 0.14.1, но у вас будет werkzeug 0.15.4, что несовместимо.

Переустановка werkzeug и jinja работала на меня.

pip install jinja2>=2.10.0
pip install werkzeug>=0.15.0

Проблема известна и описана здесь, в lists.apache.org/x/thread.html/…

Мы удалили несовместимую библиотеку Werkzeug из Apache Master в эти выходные. Это вызвало сбой установки Airflow.

Чтобы решить эту проблему, вручную установите библиотеку werkzeug в правильной версии:

pip install werkzeug>=0.15.0

Как объясняется в списке рассылки, это временная проблема, и это решение - обходной путь. Проблема возникла в версии 1.10.3.