.net - установить - установка net framework 4.5 на windows xp




.NET 4.5 RC Framework CLR-совместимость с Windows XP (2)

Вкратце мой вопрос: «Можно ли установить .NET Framework 4.5 на компьютеры с Windows XP?»

У меня есть следующая ссылка MSDN:

Версии и зависимости .NET Framework

Каждая новая версия .NET Framework сохраняет функции предыдущих версий и добавляет новые функции. CLR идентифицируется собственным номером версии. Некоторые версии .NET Framework включают новую версию CLR, но другие используют более раннюю версию. Например, .NET Framework 4 включает CLR 4, но .NET Framework 3.5 включает CLR 2.0. (Не было версии 3 CLR.) Хотя .NET Framework 4.5 RC является обновлением на месте .NET Framework 4, базовый номер версии CLR равен 4.5. ...

Далее в документации говорится, что вы можете установить только .NET Framework 4, .NET Framework 3.5 с пакетом обновления 1 (SP1), .NET Framework 2.0 с пакетом обновления 2 (SP2) в Windows XP Professional и Windows XP Home Edition (то есть не упомянуто 4.5).

В других местах я читал, что .NET 4.5 можно установить на Win XP. Так что эта документация просто ссылается на 4.5RC (а не на окончательную версию 4.5).

Моя проблема в том, что мы не можем развертывать приложения, созданные на 4.5, на машинах с XP. Выпустит ли Microsoft пакет обновления? (вряд ли, поскольку они не поддерживают XP)

PS пара интересных статей на эту тему:

.NET 4.5 - это обновление на месте до .NET 4.0

Изменения в .NET 4.5 - проблемы совместимости между .NET Framework 4 и .NET Framework 4.5 R


Как уже говорилось в этой link , .NET 4.5 не будет поддерживаться Windows XP.

Любой желающий может проголосовать за поддержку Windows XP в .net framework 4.5 here


Просматривая документы по системным требованиям .NET Framework, я думаю, вам не повезло.

http://msdn.microsoft.com/en-us/library/8z6watww(v=vs.110).aspx

Согласно документу, наверняка, его не было в тестовой матрице, вы не получите поддержку для установки. Программа установки все еще может работать, если она явно не блокирует неподдерживаемые ОС ». YMMV.

Начиная с 2014 года XP будет иметь расширенную поддержку - вы увидите только критические исправления безопасности, а не новые функции, подобные этой.

http://support.microsoft.com/lifecycle/search/default.aspx?alpha=Windows+XP





.net-4.5