linux - 让python Numba使用python 2.7在Ubuntu 14.10或Fedora 21上运行




python-2.7 ubuntu-14.10 (7)

最近,我有一个令人沮丧的时间让python Numba在Ubuntu或Fedora Linux上工作。 主要问题是llvmlite的编译。 我需要安装什么才能正确编译?


对于Fedora 23

首先检查您是否拥有最新的pip版本:

pip install -U pip
pip install -U wheel

然后安装以下pacakges:

dnf install zlib zlib-devel libstdc++-devel libstdc++ libstdc++-static llvm-3.7.0 llvm-devel-3.7.0 libedit libedit-devel
pip install enum34 funcsigs

然后从GIT存储库下载并解压缩llvmlite 。 假设您正在下载到/usr/local/llvmlite然后:

git clone <address-for-llvmlite.git> /usr/local/llvmlite
cd /usr/local/llvmlite

如下所述构建源代码:

LLVM_CONFIG=/usr/bin/llvm-config python setupy.py build

刷新终端会话并安装内置的llvmlite

reset
LLVM_CONFIG=/usr/bin/llvm-config python setup.py install

最后下载并安装numba

pip install numba    

对于Ubuntu 16.04:

LLVM_CONFIG=/usr/bin/llvm-config-3.7 pip install llvmlite

对于ubuntu 15.10

fisrt检查pip是否有正确的版本:

pip install --upgrade pip
pip install --upgrade wheel

pip> = 8.1

$ pip --version
pip 8.1.1 from
$ wheel version
wheel 0.29.0

apt-get install llvm stuff:

sudo apt-get install zlib1g zlib1g-dev libedit2 libedit-dev
sudo apt-get install llvm-3.7 llvm-3.7-dev llvm-dev

然后使用pip(警告llvmlite仅适用于llvm 3.7):

pip install enum34 funcsigs
LLVM_CONFIG=/usr/bin/llvm-config-3.7 pip install llvmlite
LLVM_CONFIG=/usr/bin/llvm-config-3.7 pip install numba

llvmlite有变化。 由于版本llvmlite-0.6.0 llvm-3.6是必需的。 现在正确安装:

sudo apt-get install zlib1g zlib1g-dev libedit2 libedit-dev llvm-3.6 llvm-3.6-dev llvm-dev
pip install enum34 funcsigs
LLVM_CONFIG=/usr/bin/llvm-config-3.6 pip install llvmlite
LLVM_CONFIG=/usr/bin/llvm-config-3.6 pip install numba

如果其他人最近有这个问题,根据他们的github页面...

“llvmlite适用于Python 2.7和Python 3.4或更高版本。从版本0.17.0开始,llvmlite需要LLVM 4.0。它不支持早期或更高版本的LLVM。

他们有一个与什么有效的兼容性表。 所有最近的包都可以从他们的网页上获得


感谢@SevakPrime

对于Ubuntu 14.04

sudo apt-get install zlib1g zlib1g-dev libedit2 libedit-dev llvm-3.6 llvm-3.6-dev llvm-dev
pip install enum34 funcsigs
LLVM_CONFIG=/usr/bin/llvm-config-3.6 pip install llvmlite
LLVM_CONFIG=/usr/bin/llvm-config-3.6 pip install numba

更新日期01/2016


最初我没有得到它在这里的评论,然后我发现:1。同时需要llvm 3.6而不是3.5和2.对我来说LLVM_CONFIG env变量不起作用。 所以我安装了这样的numba:

sudo apt-get install zlib1g zlib1g-dev libedit-dev llvm-3.6 llvm-3.6-dev llvm-3.6-runtime llvm-3.6-tools
sudo pip install enum34 funcsigs
sudo mv /usr/bin/llvm-config /usr/bin/llvm-config_bak
sudo ln -s /usr/bin/llvm-config-3.6 /usr/bin/llvm-config
sudo pip install llvmlite
sudo pip install numba
sudo mv /usr/bin/llvm-config_bak /usr/bin/llvm-config

(试过Ubuntu 14.04。)







ubuntu-14.10