firebase谷歌 - iOS-Firebase错误:使用未解析的标识符FIRApp运行提供的代码




firebase教程 (8)

尝试配置XCode以使用Firebase 3时,使用安装文档中的代码会给出错误:

https://firebase.google.com/docs/ios/setup#add_the_sdk

import UIKit
import Contacts
import Firebase

@UIApplicationMain
class AppDelegate: UIResponder, UIApplicationDelegate {

    var window: UIWindow?

    //contacts
    var contactStore = CNContactStore()


    func application(application: UIApplication, didFinishLaunchingWithOptions launchOptions: [NSObject: AnyObject]?) -> Bool {
        FIRApp.configure() <-- Use of unresolved identifier 'FIRApp'
        // Override point for customization after application launch.
        return true
    }

事实证明,hoangpx答案是修复bug的正确方法,更改pod模块的名称会有所帮助。 但请记住,当您尝试运行pod安装时,它会出现(或者如果尚未修复):

Note: as of Cocoapods 1.0 'pod repo update' does not happen on 'pod install' by default.

这意味着您应首先执行pod Firebase update以便更新到版本3.2.0及更高版本的pod install


像这样解决这个问题:

import FirebaseAnalytics

然后需要将FIRApp替换为FirebaseApp因为不推荐使用FIRApp

谢谢。


将cocoapods更新到版本1.0.x然后pod安装解决了我的问题

pod --version(查看当前版本)


尝试从podfile中删除pod,然后执行'pod install' 。 添加'pod install'然后再执行'pod install' 。 清理工作区,然后构建它。 它花了我几次尝试,但最终为我工作。


我刚刚通过将Firebase.configure()更改为FIRApp.configure()来恢复它

寒意:)


我有同样的错误,很容易解决。 关闭项目。 打开pod文件然后从中更新

pod 'Firebase', '>= 2.5.1'

pod 'Firebase/Core'
pod 'Firebase/Database'

然后打开终端,找到项目文件夹中的pod文件,输入: pod update 。 确保你看到2行

Installing Firebase 3.2.0 (was 2.5.1)
Installing FirebaseDatabase (3.0.1)

然后你很高兴去


我认为这是正确的解决方案:

  1. pod repo update
  2. pod update

但我遇到了同样的问题并解决了它在命令行上执行以下步骤:

  1. pod repo update
  2. 从我的Podfile中注释了pod'Firebase pod 'Firebase'
  3. pod install (这删除了旧的Firebase)
  4. 再次添加了pod 'Firebase'
  5. pod install (添加了新的Firebase)

第二步和第三步是我认为的关键,否则CocoaPods没有尝试更新它。 正如我所说,也许这可以通过pod update解决,但现在我不能再回去再试一次。

完成所有这些之后,您应该看到以下内容: Installing Firebase (3.2.0) Installing FirebaseAnalytics (3.2.0) Installing FirebaseInstanceID (1.0.6) Installing GoogleInterchangeUtilities (1.2.1) Installing GoogleSymbolUtilities (1.1.1) Installing GoogleUtilities (1.3.1)


所有其他答案都是现场,但听起来你已经覆盖了那些东西。 确保您使用的是CocoaPods 1.0(或更高版本)并指定了use_frameworks! 在你的Podfile中。

如果您正在升级,那么首先要清除我们的Pods /目录并且可能正在运行pod deintegrate以恢复到零状态。