ios - Flutter:如何修复ITMS-90809:不推荐使用的API使用-Apple将停止接受使用UIWebView API的应用程序的提交




(2)

我有我们的Cordova应用程序并通过更新依赖项修复它。

您是否有机会使用依赖项或其他依赖项使用依赖项“cordova-plugin-inappbrowser”。

如果是这样,这应该在3.1.0中修复。 请参阅发布说明 https://github.com/apache/cordova-plugin-inappbrowser/blob/master/RELEASENOTES.md 和PR修复它 https://github.com/apache/cordova-plugin-inappbrowser/pull/271

更新:它尚未修复。 请参阅cordova-ios上的问题: https://github.com/apache/cordova-ios/issues/661https://github.com/apache/cordova-ios/issues/661 请注意:没有截止日期,我已经联系了一位苹果开发人员,他一直在发推文关于转移到WKWebView以查看是否他可以提供更多信息,如果得到回复,我会更新。

在提交我的最新版本时,Apple突然回复了一条消息,说明存在问题,具体而言:

ITMS-90809:不推荐使用的API使用 - Apple将停止接受使用UIWebView API的应用程序的提交。 有关更多信息,请参阅 https://developer.apple.com/documentation/uikit/uiwebview

由于我没有使用webview插件,所以我不知道 UIWebView API 的使用位置。 关于如何解决这个问题的任何建议?

此错误出现在最新的稳定颤振版本1.7.8 + hotfix.4中,并包含以下软件包:

http: ^0.12.0
shared_preferences: ^0.4.3
intl: any
permission_handler: ^2.1.2
contacts_service: ^0.2.8
image: ^2.0.5
cached_network_image: ^1.0.0
url_launcher: ^5.0.1
path_provider: ^0.5.0+1
after_layout: ^1.0.7
connectivity: ^0.4.3+1
device_info: ^0.4.0+2
firebase_auth: ^0.11.1+7
firebase_messaging: ^5.1.2
firebase_analytics: ^5.0.0
notification_permissions: ^0.4.0

所有软件包都已更新到最新版本。

flutter doctor 的输出是:

[] Flutter (Channel stable, v1.7.8+hotfix.4, on Mac OS X 10.14.6 18G87, locale en-US)Flutter version 1.7.8+hotfix.4 at /Users/per/flutter
    • Framework revision 20e59316b8 (6 weeks ago), 2019-07-18 20:04:33 -0700Engine revision fee001c93f
    • Dart version 2.4.0

[] Android toolchain - develop for Android devices (Android SDK version 28.0.3)Android SDK at /Users/per/Library/Android/sdk
    • Android NDK location not configured (optional; useful for native profiling support)Platform android-28, build-tools 28.0.3Java binary at: /Applications/Android Studio.app/Contents/jre/jdk/Contents/Home/bin/java
    • Java version OpenJDK Runtime Environment (build 1.8.0_152-release-1136-b06)All Android licenses accepted.

[] Xcode - develop for iOS and macOS (Xcode 10.3)Xcode at /Applications/Xcode.app/Contents/DeveloperXcode 10.3, Build version 10G8CocoaPods version 1.7.4

[] iOS tools - develop for iOS devices
    • ios-deploy 1.9.4

[] Android Studio (version 3.2)Android Studio at /Applications/Android Studio.app/ContentsFlutter plugin version 31.3.1Dart plugin version 181.5656Java version OpenJDK Runtime Environment (build 1.8.0_152-release-1136-b06)

[] VS Code (version 1.31.1)VS Code at /Applications/Visual Studio Code.app/ContentsFlutter extension version 2.25.1

[] Connected device (1 available)Nexus 6P5VT7N15C31001152 • android-arm64 • Android 8.1.0 (API 27)No issues found!

我认为它是从firebase_auth插件中使用的。 尝试将其更新到最新版本,然后记住运行 pod更新