android - 无效的SplitApkBundle。 该捆绑包针对未知语言:[gr]。 谷歌播放控制台




android-studio google-play-console (3)

将此应用到Android {}

bundle {
    density {
        // Different APKs are generated for devices with different screen densities; true by default.
        enableSplit true
    }
    abi {
        // Different APKs are generated for devices with different CPU architectures; true by default.
        enableSplit true
    }
    language {
        // This is disabled so that the App Bundle does NOT split the APK for each language.
        // We're gonna use the same APK for all languages.
        enableSplit false
    }
}

Android应用捆绑包上传失败,出现错误

Invalid SplitApkBundle. The bundle targets unknown languages: [gr]

Android Studio版本3.5

我试过了

  1. 清理和重建
  2. 使缓存/重启无效

就我而言,是因为我使用的是Facebook帐户工具包,看到井回答它对我有帮助,我在这里整理以供将来参考

bundle {
    density {
        // Different APKs are generated for devices with different screen densities; true by default.
        enableSplit true
    }
    abi {
        // Different APKs are generated for devices with different CPU architectures; true by default.
        enableSplit true
    }
    language {
        // This is disabled so that the App Bundle does NOT split the APK for each language.
        // We're gonna use the same APK for all languages.
        enableSplit false
    }
}

我遇到过同样的问题。
无效的SplitApkBundle。 该捆绑包针对未知语言:[cb]

我通过设置DSL来停止Aapt软件包构建错误的语言目标的方法。

我的应用程序支持英语和中文,因此resConfigs只需要en和zh。

defaultConfig {
    ...
    resConfigs "en", "zh-rTW", "zh-rCN"
}




android-app-bundle