ios - 使用Xcode 11.2(11B52)存档的应用被拒绝:ITMS-90534:无效的工具链




app-store toolchain (2)

Apple已于2019年11月5日弃用Xcode 11.2

始终可行的解决方法(手动下载)

从此处下载xip文件

也:

最新发行版 (Xcode 11.2.1)

要么

最新Beta版 (Xcode 11.3 Beta)

要么

您需要的任何版本 。 以及所有其他可下载内容

然后解压缩并将其移动到您喜欢的位置。

您可以 在这里 找到 所有解决此问题的方法。

我已经从商店安装了Catalina和Xcode 11,它们是最新的:

  • 卡塔琳娜州:10.15.1(19B88)
  • Xcode:11.2(11B52)

昨天,我使用 fastlane 上传了一个新的二进制文件。 今天,我从苹果公司得到了这个信息:

亲爱的开发人员,

我们在最近提交给您的应用程序“GözenSecurity” 7.3.2(67)的App Store审核中发现了一个或多个问题。 请更正以下问题,然后重新上传。

ITMS-90534:无效的工具链-您的应用是使用不受支持的Xcode或SDK版本构建的。 如果您打算将此构建提交到App Store,请确保使用的是GM版本的Xcode 10.1和iOS 12.1的SDK,以及watchOS 5.1,tvOS 9的Xcode 7.1和SDK,或者Xcode 6和macOS的SDK 10.9或更高版本。 如果您使用的是Xcode Beta版来测试您的应用,请确保您使用的是最新支持的版本。 有关受支持的Beta版本的更多信息,请查看App Store Connect新增功能页面( https://developer.apple.com/app-store-connect/whats-new/ )。

最好的祝福,

App Store团队

自从 CatalinaXcode 11 正式发布以来,为什么 Apple 仍然希望我使用 Xcode 10iOS 12


Xcode已更新为11.2.1版本。 在Xcode版本11.2中进行的构建不再有效。 如果您在Mac App Store中看不到更新,请转到您的开发人员帐户并手动下载新的Xcode。





macos-catalina