java - map使用 - implementation com google android gms play services ads




导入无法解析:import com.google.android.maps。*; (4)

确保你有

<uses-library
        android:name="com.google.android.maps" />

在你的应用程序清单中,并且你已经下载了不仅2.0 SDK,而且还有2.0-with-google-APIs SDK。 然后在Eclipse中设置项目的属性,以检查所需SDK的Google API版本。 然后尝试清理你的构建(在Eclipse中的Project-> Clean;从命令行“ant clean”)。

我成功地在我的应用程序中使用谷歌地图,但随后需要将Android SDK版本从1.5更改为2.0。 现在Google地图的导入无法解析。


1.使用sdk manager安装所有的google API。

2.在清单中,在应用程序元素下添加

     <uses-library android:name="com.google.android.maps" />

3.你也必须包含地图的jar文件。右键点击你的项目,然后建立路径,然后添加外部档案。 找到您的sdk。 Android的SDK-WINDOWS \插件\ addon_google_apis_google_inc_8 \库\图


您可能还需要将google-play-services_lib添加到项目的库列表中。 这样做为我解决了这个问题。

右键单击project-> properties-> Android

单击“库参考/项目”表右侧的“添加...”按钮。

如果您已经使用SDK管理器下载了Google Play服务库,您应该在按下“添加”按钮时弹出的“项目选择”框中选择该库。

如果您还没有下载Google Play服务,请按照以下说明进行操作: http//developer.android.com/google/play-services/setup.html


执行右键单击“属性” - >“Android”,选择“目标名称” Google API而不是Android xx为我解决了这个问题。





google-maps