python-2.7 range - 在pip上為python 2.7安裝py2exe:這個包需要Python 3.3或更高版本



of out (5)

你可以從here直接下載py2 2.7 for python 2.7

>>> python -c "import sys; print sys.version"
2.7.6 (default, Nov 10 2013, 19:24:18) [MSC v.1500 32 bit (Intel)]

>>> pip --version
pip 1.5.5 from C:\Python27\lib\site-packages (python 2.7)

>>> pip install py2exe
<mumble grumble..>
RuntimeError: This package requires Python 3.3 or later

雖然官方py2exe下載頁面說他們正是我需要的:

那麼如何在pip上安裝py2exe呢?


我正在使用Anacona,我通過其環境功能安裝py2.7,所以之前的答案對我沒有幫助。

--------------------------- Cannot install ---------------------------  
Python version 2.7 required, which was not found in the registry. 

以下是我使用的命令,它可以通過命令行安裝py2exe。

pip install https://nchc.dl.sourceforge.net/project/py2exe/py2exe/0.6.9/py2exe-0.6.9.zip
...
Successfully installed py2exe-0.6.9

原因py2exe需要Microsoft Visual C ++ 9.0,因此在安裝之前,您應該通過此link下載並安裝它

希望這可能會有所幫助,謝謝。


pypi缺少它,如果你點擊0.6.9鏈接它會帶你到0.9.2.0 python 3包,似乎沒有0.6.9包可供下載。

嘗試使用pip install http://sourceforge.net/projects/py2exe/files/latest/download?source=files



對於任何使用MariaDB而不是MySQL的人來說,解決方案是安裝libmariadbclient-dev軟件包並使用正確的名稱創建一個符號鏈接到配置文件。

例如這為我工作:

ln -s /usr/bin/mariadb_config /usr/bin/mysql_config




python python-2.7 pip py2exe pypi