javascript - 假陽性“詞法聲明需要ECMAScript 6”和“TypeScript 1.x功能。 當前語言是1.4“錯誤消息



resharper ecmascript-6 (1)

看來我的版本Resharper(10.0.1)無法檢測TypeScript版本。

要解決這個問題,你可以手動指定版本。 由於此版本的Resharper(此時最新發布)不支持TypeScript 1.7,因此需要使用TypeScript 1.6。

在將TypeScript更新到版本1.7(目前的最新版本)後,我已經看到Resharper指出錯誤,例如,當使用namespaceconstlet ,即使它們應該受此版本的TypeScript支持。

例如:

TypeScript 1.x功能。 當前的語言是1.4

詞法聲明(let和const)需要ECMAScript 6編譯器目標。 目前的目標是ECMAScript 5。





typescript1.7