jquery-ui - pie - jquery chart free




使用“npm install”安裝jquery-ui (3)

我在這裡看到https://github.com/jquery/jquery-ui的最新版本是1.11.4。 但是,當我使用“npm install jquery-ui”時,它只有1.10.3。 我在node_modules/jquery-ui/jquery-ui.js檢查了這個版本。

我有什麼方法可以安裝最新版本嗎?


TJ給出了正確答案,但它有點短/太通用......

GitHub項目位於https://github.com/jquery/jquery-ui/
所以真正的命令是npm install github:jquery/jquery-ui (你甚至可以跳過github:因為npm默認為它)。
但這會給你帶來最新的,不穩定的版本(寫作時大約1.12),當我嘗試時它甚至都沒有用。
因此,最好獲取標記版本:

npm install github:jquery/jquery-ui#1.11.4

通用註釋:AFAIK,如果項目沒有package.json文件,這種安裝仍然可能失敗。


jQuery-ui特別需要在安裝後構建。 要避免這種情況,請使用npm install jquery-ui-dist


這是當前最新版本(1.11.4),涼亭正在使用的相同包,包括所有主題。

npm install github:components/jqueryui#1.11.4





npm-install