node.js - update - nvm




將npm降級為舊版本 (4)

即使我運行 npm install -g [email protected] ,也不適合我。

最後,我下載並安裝舊的node.js版本。

https://nodejs.org/download/release/v7.10.1/

它是npm版本4。

你可以在這裡選擇任何版本 https://nodejs.org/download/release/

我嘗試更新npm以查看它是否能解決我們遇到的一些依賴性問題,現在我想降級到開發團隊其餘部分正在使用的版本。 如何安裝舊版本?

我根據 安裝頁面 上的說明更新了npm:

更新npm

Node安裝了npm,因此你應該有一個npm的版本。 但是,npm比Node更頻繁地更新,因此您需要確保它是最新版本。

npm install [email protected] -g


只需將 @latest 替換為您要降級到的版本號即可。 我想降級到版本3.10.10,所以我使用了這個命令:

npm install -g [email protected].10.10

如果您不確定應使用哪個版本,請查看 版本歷史記錄 。 例如,您可以看到3.10.10是npm 3的最新版本。


在做之前從URL下載節點Js 8.11.3: download

打開命令提示符並運行:

npm install -g [email protected]

使用此版本,這是與cordova 7.1.0一起使用的穩定版本

安裝cordova使用:•npm install -g [email protected]

•運行命令

•Cordova平台刪除android(如果你有舊的android代碼或代碼有一些問題)

•Cordova平台添加android:用於在cordova中構建android應用程序運行:Corodva運行android


npm install -g [email protected]

這將在主要版本4上安裝最新版本,不需要指定版本號。 將4替換為您想要的任何主要版本。





downgrade