iphone - 無法更新ios - 舊ipad更新




沒有配置的iOS設備可用兼容的iOS版本 (11)

“沒有配置的iOS設備可用於兼容的iOS版本。將iOS設備連接到最新版本的iOS以運行您的應用程序或選擇iOS模擬器作為目標。”

嘗試在我的設備上構建時,我遇到了同樣的問題。 然後我意識到我正在使用售後市場的領先優勢。 將領先優勢改為原來的iPhone領導......嘿Presto!

我正在嘗試在iPhone 3G上測試我的應用程序,但是我收到此錯誤:

沒有配置的iOS設備可用兼容的iOS版本。 將iOS設備與最新版本的iOS連接以運行您的應用程序或選擇iOS模擬器作為目標。

注意:

  • 3G安裝了iOS版本4.2.1
  • iOS部署目標設置為4.2版
  • 該設備已安裝有效的開發配置文件
  • 我正在使用最新的Xcode 4

我很茫然。 有人可以幫忙嗎?

蒂姆


不確定,我理解您的設置正確。 但是,規則是:

  • Base SDK Version> =開發設備iOS版本
  • 部署目標版本=要支持的最低iOS版本。

因此,我猜,設置基本SDK版本等於或高於4.2.1可能會有所幫助。


嘗試在Xcode管理器中單擊設備上的“用於開發”。 我得到了同樣的錯誤,這是我修復它的唯一方法。


在Organizer中,我不得不將配置文件從一般的“配置文件”部分複制(拖放)到設備的“配置文件”部分。


我也得到這種情況:當我重置iphone,插件再次xcode,xcode不認識iphone架構,iphone仍有完整的配置我去管理器窗口,再次檢查設備,看到我的iPhone沒有綠燈,並有按鈕,要求使用此設備進行開發。 點擊按鈕,一切順利


我有Xcode 5.0,並嘗試使用iOS 5.1.1為我的iPad構建。 我收到消息:沒有配置的iOS設備可用兼容的iOS版本。 將iOS設備與最新版本的iOS連接以運行您的應用程序或選擇iOS模擬器作為目標。

您可以在4個步驟中看到的解決方案:

(1)選擇項目設置 > 項目設置 > 信息 。 選擇部署目標而不是7.0即6.1。

(2)選擇項目設置 > 項目設置 > 構建設置 。 改變架構。 不要為64位編譯。

(3)選擇項目設置 > 目標設置 > 常規 。 根據您的設備iOS版本設置部署目標 。 之後,在運行IOS設備後出現設備名稱IPad

(4)最後我選擇了iPad。


我解決了這個問題,只需更改以下圖片的iOS設備即可iPhone Retine ....


我遇到了類似的問題,此錯誤消息:“沒有配置的iOS設備可用於兼容的iOS版本。將iOS設備與最新版本的iOS連接以運行您的應用程序或選擇iOS模擬器作為目標。”

我通過簡單地轉到“跳轉欄”並將其從“iOS設備”更改為iPad 6.0模擬器來解決它。“


當我將我的應用程序從iPhone更改為通用時,xCode會自動將部署目標從4.3更改為6.1,我的設備有6.0,因此無法識別。

將值更改回4.3解決了問題。


第一次,您的新測試iOS連接到Mac時,您無法在彈出菜單中看到它。 只有“IOS設備”您可以嘗試從菜單:窗口 - >管理器 - >設備; 然後選擇你連接iPad並點擊“用於開發”;所以它出現了。


通過關閉並重新打開xcode解決了這個問題。

Xcode ......這是新的Windows。





ios-provisioning