ruby - update - ubuntu install gem




你如何降級rubygems? (4)

我已經安裝了rubygems 1.3.1,但我想回到1.2.0。 什麼是降級rubygems的命令?


2011年11月更新:現在RVM退出了,請運行rvm install rubygems <version>


在舊的Rails 3堆棧中,我遇到了類似的問題。 發生這些類型的問題時,我的建議是轉到應用程序當前正在運行的生產服務器上,並檢查它使用的是哪個rubygems版本:

gem -v

對我而言,它使用1.8.24。 所以我所需要做的就是降級從“rvm install 1.9.3”生成的當前rubygems,當時我為這個應用程序安裝了舊的ruby。 我運行了以下命令:

 $ rvm install rubygems 1.8.24 --force

它的工作。 注意我正在運行Ubuntu 14.04,我使用的服務器也是Ubuntu。


我使用這個命令返回到我的ruby版本所需要的gem版本:

rvm rubygems current

如果它給校驗和錯誤嘗試

rvm rubygems current --verify-downloads 1

這對我來說是訣竅。






rubygems